Eclipse – Could not find App.apk!

Posted on August 19, 2011

1


I started running into trouble with Eclipse this morning when I was trying to build and install an app onto my phone. The project seemed to build Ok and I got no obvious errors in the console during packing  but when  ADB tried to push the .apk to the phone I kept getting this error in the console

[2011-08-19 10:06:06 - App] Android Launch!
[2011-08-19 10:06:06 - App] adb is running normally.
[2011-08-19 10:06:06 - App] Could not find App.apk!

After a few hours of banging my head against the wall I remembered that before I powered down my laptop the previous day I’d updated the Android SDK using the SDK and AVD Manager.  After a little investigation it turns out the version of Eclipse I’m using(Ganymede – 3.4) is not compatible with the latest version of the SDK(r12.) The quick solution: update my Eclipse install, problem solved.

I wish I’d done this sooner, the Latest Eclipse version(Indigo) is very nice indeed!

Advertisements
Posted in: Uncategorized